This project is read-only.

Control cannot be created. No skin loaded.

Feb 13, 2011 at 8:14 PM


I downloaded your Framework and tried it out! But i have one problem. If i compile your Samples you throw a new Exception:

throw new Exception("Control cannot be created. No skin loaded.");


How can i fix it?




Feb 18, 2011 at 7:18 PM

The skinning system for this framework can be a pain sometimes. I downloaded it again and ran the samples. Getting started sample worked fine. But the ScrollBar sample threw the exception you are describing.

Something really needs to be done about why the skinning system can seem so hard to get working sometimes. Other then that, once you get it running it can be a great GUI system.

I've tried extracting the *.skin files into there own folders, and that does not help either, *.skin files are just zip files renamed.  I had this same issue when I started working with this framework, and eventually got it working but it was so long ago I can't recall what it was I did to get it running.

Keep trying and you should be able to get it working eventually.

Feb 20, 2011 at 3:58 PM

I was not able to run the Sample projects.

Instead I created a new XNA Game Project, added the Neoforce lib and copied the Skins folder (provided with the sample projects) to my Game/Content/ folder.

XNA 4.0 creates a separeted project for the Content resources. Its uggly that I need to create a folder named Content inside the main project, but that was what I had to do for now.

Do not create the folder using Visual Studio. I tried it and it cannot compile the .skin file. Just copy and paste it to your solution folder.


I do not know if it can create any issue when releasing the game.