This project is read-only.
2
Vote

Unable to import skins

description

First of all, I just started playing around with this, so it's possible I missed something. However, when I added the default skin to the content piple project and set the importer to neoforce, I cannot build. Here is the error:
 
 
Error 1 Building content threw XmlException: Data at the root level is invalid. Line 1, position 1.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.Throw(String res, String arg)
at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace()
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlTextReaderImpl.Read()
at System.Xml.XmlLoader.Load(XmlDocument doc, XmlReader reader, Boolean preserveWhitespace)
at System.Xml.XmlDocument.Load(XmlReader reader)
at System.Xml.XmlDocument.Load(String filename)
at TomShane.Neoforce.Importers.SkinImporter.Import(String filename, ContentImporterContext context)
at Microsoft.Xna.Framework.Content.Pipeline.ContentImporter1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetDirectly(BuildItem item, String importerName)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.RunTheBuild()
at Microsoft.Xna.Framework.Content.Pipeline.Tasks.BuildContent.RemoteProxy.RunTheBuild(BuildCoordinatorSettings settings, TimestampCache timestampCache, ITaskItem[] sourceAssets, String[]& outputContent, String[]& rebuiltContent, String[]& intermediates, Dictionary
2& dependencyTimestamps, KeyValuePair`2[]& warnings) c:\users\van\documents\visual studio 2010\Projects\Sandbox\Sandbox\SandboxContent\Default.skin Sandbox

comments

onedeadgod wrote Feb 25, 2011 at 7:59 PM

Just as I thought. I added a reference to the content importer dll to the main project and I guess that is what caused the conflict.

wrote Feb 14, 2013 at 8:52 PM

Sonorhio wrote Aug 30, 2013 at 9:34 PM

I've the same problem... Someone have the solution ?

wrote Aug 30, 2013 at 9:40 PM